Warning: Memcache::get() [memcache.get]: No servers added to memcache connection in /home/measured/public_html/libs/phpcache/drivers/phpcache.driver.memcached.class.php on line 75

Warning: Memcache::get() [memcache.get]: No servers added to memcache connection in /home/measured/public_html/libs/phpcache/drivers/phpcache.driver.memcached.class.php on line 71

Warning: Memcache::add() [memcache.add]: No servers added to memcache connection in /home/measured/public_html/libs/phpcache/drivers/phpcache.driver.memcached.class.php on line 65
ford motor company Complaint - Ford electrical problems - electrical problems
ford motor company Complaint

ford motor company Complaint

ADVERTISEMENT

Ford electrical problems - electrical problems


2002 FORD EXCURSION ELECTRICAL PROBLEMS:
On Monday, June 8, 2009 I stopped by my local FORD dealership to find a solution to yet another electrical problem. The front windshield wipers would NOT turn OFF, return to the rest position or stop, no intermittent functions available, and they would not turn OFF even when the ignition was turned off. The fuse had to be removed to stop the wiper motor operation. The dealership said that the wiper motor was bad and needed to be replaced.

Upon leaving the dealership I noticed the left mirror turn signal, front left signal, and dash signal indicator were inoperative. While driving the vehicle the smell of wires burning was noticed with a small plume of smoke viewed coming up from the upper LEFT side of the steering column shroud (not the steering wheel). The battery was immediately disconnected.

Upon inspection NO fuses were blown. All fuses checked out good.

Both front turn signal bulbs were replaced, yet the left turn signal(s) would not operate.

Upon closer inspection of the steering column area NO wires were found burned, damaged, or frayed. However, a turn signal wire harness was found unplugged. It was snapped back into place and the signals were operative again. ALL electrical components appear operative with the following exception.

While in PARK, w/ignition key on, while checking light functions, the back-up sensor alarm went on (beeping) momentarily (twice). After several repeated attempts the incident did NOT re-occur.

1). Alternator and battery replaced at 42,769 miles, the drivers seat motor was found inoperative after servicing appointment at time of pick up and was replaced.

2). Speed control deactivation switch replaced at 48,584 miles, recall item.
3). Driver’s door window switch replaced at 58,504 miles.

4).Keyless entry system replaced at 59,952 miles, a module caught fire during servicing and was replaced.
5). Front wiper motor replaced on 06/10/2009 by customers mechanic.

6). Vehicles on its third battery.


Share This Review:



         


Is this your Business? Claim Your Business Free and reply to this customer

CONTACT THIS BUSINESS

Post a reply for this review COMMENT
WRITE to ford motor company
SUBMIT a ticket
for ford motor company
WATCH videos
for ford motor company
More ford motor company Reviews and Complaints MORE reviews and complaints
for ford motor company

BUSINESSES REPLY HERE

Claim this company BUSINESSES: CLAIM YOUR BUSINESS NAME FREE
Respond to this review BUSINESSES: REPLY TO THIS CUSTOMER NOW
Link to MeasuredUp BUSINESSES: Free Customer Service Excellence Badge
Take the pledge BUSINESSES: Free Customer Service Pledge Badge
Upgrade Account BUSINESSES: Build your customer service online reputation


ADVERTISEMENT


Comments

login with Facebook and share your reviews

More ford motor company reviews


Similar reviews


[Top]

Bookmark/Share this page

This page is under construction.
It will be up and running soon with new features to make you smile more.
Thanks,
The MeasuredUp Team